Device requirements and compatibility

You can create Flipgrid videos on most browsers and mobile devices. You can find more details about specific devices and browsers that are compatible with Flipgrid. 

To check if your system meets the minimum requirements, visit our system check.

  1. Browser requirements
  2. Computers without cameras
  3. iOS and Android devices
  4. #Flipgrid AR compatibility
  5. Other devices

Important: Please make sure you're using the latest version of the Flipgrid app.

Browser requirements

Flipgrid works best with the new Microsoft Edge. However, Flipgrid supports multiple browsers. Here, you can review aspects of your browser that are compatible with Flipgrid.

Microsoft Edge
New Edge Old Edge
Aspects
  • Video recording: Compatible - Built-in (WebRTC)
  • Video playback: Compatible - Native (MP4)
Requirements
  • Minimum version: Last 2 versions

Conclusion: The overall experience can be categorized as "Super awesome."

Google Chrome
Aspects
  • Video recording: Compatible - Built-in (WebRTC)
  • Video playback: Compatible - Native (MP4)
Requirements
    • Minimum version: Last 2 versions

Conclusion: The overall experience can be categorized as "Super awesome."

Firefox
Aspects
  • Video recording: Compatible - Built-in (WebRTC)
  • Video playback: Compatible - Native (MP4)

Requirements

  • Minimum version: Last 2 versions

Conclusion: The overall experience can be categorized as "Awesome."

Safari

Important: Apple recently updated to Safari 15+. Currently, video recording is unavailable in this latest version of Safari. We highly recommend using a modern browser such as Google Chrome or the new Microsoft Edge. You can also use the free Flipgrid app iOS and Android devices.

Aspects

  • Video recording:
    • v12: Semi-compatible - Upload clip only
    • v14+: Compatible - Built-in (WebRTC)
  • Video playback: Compatible - Native (MP4)

Requirements

  • Minimum version: 12

Conclusion: The overall experience can be categorized as "Great."

Tips:

Mobile device requirements

  iOS Android
Video Recording Compatible Compatible
Compatible devices iPhone, iPad, iPod Touch Devices with native MP4
Minimum Version iOS 13.6 and up Android OS 6 and up
Overall Experience Super Awesome Great

 

iOS
  • Minimum version: iOS 13.6 and up
  • Compatible devices: iPhone, iPad, and iPod touch.
  • Note: Camera effects are not supported during the video and selfie step for iPhone 6, iPad Air, iPhone SE, and older devices.
Android
  • Minimum version: Android 6.0 and up
  • Note: For Android 8.0 and under, the "Trim" and "Split" camera editing functionalities are not supported.

Other devices and computers without cameras

Contact us

If these troubleshooting steps still don't provide a solution and you have any questions, we are here for you. You can contact our Support team here.


Was this article helpful?
Have more questions? Contact Support